• Willkommen, SF Webdesign. Bitte Anmelden.
 

Inoffizielle deutsche Sprachdateien für SMF 2.1 RC*

Erstellt von Franky, 26.09.2017, 03:39:19

Vorheriges Thema - Nächstes Thema

0 Mitglieder und 1 Gast schauen sich dieses Thema an.

Franky

RC1 steht vor der Tür. Sämtliche Dateien auf Github wurden schon auf RC1 geändert. Die Entwickler sind eifrig am Testen und beheben noch Bugs. Noch ein wenig Geduld, dann gibt es neue Pakete zum downloaden.
Gruß Stephan

Franky

RC1 ist heute morgen um 08:20 auf Github veröffentlicht worden. Im laufe dieser Woche aktualisiere ich die Pakete.
Gruß Stephan

Franky

RC1 beinhaltete viele Fehler. Heute Morgen gegen 10:09 Uhr wurde RC2 veröffentlicht.

Ich rate zur Vorsicht, testet erstmal in einem Testforum und geht nicht gleich Live damit online.
Gruß Stephan

Franky

RC2 wurde wieder zurückgezogen. Vermutlich war Sesquipedalian ein bischen zu schnell gewesen :D

Screenshot_20190210-140248.jpg

Der Link View it on Github führt nun zu einer "404" Seite von Github.
Gruß Stephan

Franky

Inoffizielles Sprachpaket Deutsch Sie Form für SMF RC1

Diese Übersetzungen wurde komplett neu erstellt. Es wurde nicht mit den Übersetzungen des original Sprachpaket erstellt.

Installation:
Paket entpacken und in den root des Forums hochladen.

Hinweis!
Sprachpaket funktioniert nur mit dem offiziellen SMF RC1 Paket von Github
Gruß Stephan

Franky

Inoffizielles Sprachpaket Deutsch Sie Form für SMF RC3

Diese Übersetzungen wurde komplett neu erstellt. Es wurde nicht mit den Übersetzungen des original Sprachpaket erstellt.

Installation:
Paket entpacken und in den root des Forums hochladen.

Hinweis!
Sprachpaket funktioniert nur mit dem offiziellen SMF RC3 Paket von Github
Gruß Stephan

Franky

Es gibt wieder ein neues Paket #00298 :)

Version 2.1 RC3 ist seit 15 Oktober 2020 online und es geht Richtung RC4.

Es hat sich seit dem letzten Paket viel getan. Viel Neues und viele Bugs wurden behoben. Mittlerweile läuft RC3 ziemlich stabil. Enthält aber noch einige Bugs. Auch in der Datenbank gab es Änderungen. Daher bei einer Aktualisierung unbedingt die upgrade.php ausführen, siehe unteren Hinweis.

In RC3 funktioniert die Cache Funktion nicht. Dies ist mit Pull Request #6430 behoben worden. Dies ist in dem hier zum Download stehendem Release Paket enthalten.

Die DSGVO Funktion ist im Grunde gut umgesetzt. Die Mitglieder können sich ihre persönliche Daten, PN's und Beiträge exportieren. Nur eins ist nicht gut umgesetzt. Die Datennschutzseite. Der Link zur Datenschutzśeite ist versteckt im Footer im Link "Bedingungen und Regeln" und enthält die Registrierungs Regeln. Also nicht nur den Text zum Datenschutz. Dies dürfte Abmahnanwälte auf den Plan rufen. Hier müsste nachgebessert werden. Oder man nutzt die Interne Funktion für die Datenschutzseite nicht und erstellt eine eigene Datenschutzseite mit einem eigenen Link.


Zur Aktualisierung am besten alle Verzeichnisse und Dateien bis auf die Verzeichnisse attachments, avatars, custom_avatar, Packages und die Dateien Settings.php und Settings_bak.php, löschen.

Dann aus dem Verzeichnis other die Dateien upgrade.php, upgrade-helper.php und alle mit upgrade_* in den Root des Forums Verzeichnis einfügen dann im Browser mit www.mein-forum.dev/upgrade.php ausführen. Eventuell noch den Cache im Browser leeren.

Das Sprachpaket kann nur mit dem hier angebotenen SMF2.1-release Archiv verwendet werden!
Gruß Stephan

Franky

Es gibt wieder ein neues Paket #00299 :)

Es wurden wieder einige Bugs behoben und es gab einige Optimierungen. Die Cache Funktion funktioniert nun wieder. Und es gibt auch wieder einen Bug (Windoof läßt grüßen  :D ) . Es ist nur ein "Schönheitsfehler". Die Drobdowns vom Profil fügen sich unter dem Text des Hauptmenü. Im Adminbereich vom oberen Menü unter dem Text der Tabs. Ich vermute das es mit der letzten Änderung in der index.css. Pull Rrequest 6502, verursacht wurde.

Mit der Datums Einstellung im Profil und Admin Center gibt es noch ein Problem. Ein Pull Request ist dafür schon erstellt worden, mal schaun wann dieser freigegeben wird. In der deutschen Sprachdatei habe ich nur den für die deutschsprachigen Europäischen Ländern verwendete Sprachstring übersetzt. Das behebt etwas das Problem.

Zur Aktualisierung am besten alle Verzeichnisse und Dateien bis auf die Verzeichnisse attachments, avatars, custom_avatar, Packages und die Dateien Settings.php und Settings_bak.php, löschen.

Dann aus dem Verzeichnis other die Dateien upgrade.php, upgrade-helper.php und alle mit upgrade_* in den Root des Forums Verzeichnis einfügen dann im Browser mit www.mein-forum.dev/upgrade.php ausführen. Eventuell noch den Cache im Browser leeren.

Das Sprachpaket kann nur mit dem hier angebotenen SMF2.1-release Archiv verwendet werden!
Gruß Stephan

Franky

Neues Paket #00300
Neues gibt es nicht. Es wurden nur Bugs behoben und es gab einige Optimierungen. Wie gehabt. :)

ZitatEs ist nur ein "Schönheitsfehler". Die Drobdowns vom Profil fügen sich unter dem Text des Hauptmenü. Im Adminbereich vom oberen Menü unter dem Text der Tabs. Ich vermute das es mit der letzten Änderung in der index.css. Pull Rrequest 6502, verursacht wurde.

Es wurde von diesem Pull Request verursacht. Eine Lösung gibt es auch schon, aber noch nicht freigegeben => #6548

Zur Aktualisierung vorhandene Modifikationen und weitere Themes deinstallieren. Die Daten der Mods müssen nicht gelöscht werden. Am besten alle Verzeichnisse und Dateien bis auf die Verzeichnisse attachments, avatars, custom_avatar, Packages und die Dateien Settings.php und Settings_bak.php, löschen.

Dann aus dem Verzeichnis other die Dateien upgrade.php, upgrade-helper.php und alle mit upgrade_* in den Root des Forums Verzeichnis einfügen dann im Browser mit www.mein-forum.dev/upgrade.php ausführen. Eventuell noch den Cache im Browser leeren.

Das Sprachpaket kann nur mit dem hier angebotenen SMF2.1-release Archiv verwendet werden!
Gruß Stephan

Franky

Neues Paket #00301

Es wurden wieder Bugs behoben und Optimierungen getätigt. Erwähnenswert sind diese:

  • Der Menü Bug wurde behoben. Aber ich denke das dazu noch ein Pull request kommt.
  • SCEditor v2.1.3 auf Version v3.0.0  aktualisiert. Es wurde dafür eine neue Datei im root hinzugefügt => .editorconfig. Infos dazu =>
    chore: add .editorconfig file and initial configuration #6374 && Pull request #6374. Ob die nur während der Entwicklungsphase benötigt wird oder dauerhaft bleibt, habe ich noch keine Informationen dazu gefunden.
  • Wenn man mehrere Sprachdateien installiert hat und die Sprachauswahl aktiviert hat, kommt man jetzt nach dem Wechsel der Sprache wieder zurück zu der Seite wo man sich befand.
  • Für Drittanwendungen wurde jetzt eine Admelde Bestätingungs Hinweis eingefügt.
  • Mein deutsches Sprachpaket sind kleine Bugs behoben worden.

Hinweis! Solltet ihr nach dem Upgrade Prozess weiter im Wartungsmodus sein, öffnet die Datei Settings.php und sucht nach
ändert $maintenance zu
$maintenance = 0;
Zur Aktualisierung vorhandene Modifikationen und weitere Themes deinstallieren. Die Daten der Mods müssen nicht gelöscht werden. Am besten alle Verzeichnisse und Dateien bis auf die Verzeichnisse attachments, avatars, custom_avatar, Packages und die Dateien Settings.php und Settings_bak.php, löschen.

Dann aus dem Verzeichnis other die Dateien upgrade.php, upgrade-helper.php und alle mit upgrade_* in den Root des Forums Verzeichnis einfügen dann im Browser mit www.mein-forum.dev/upgrade.php ausführen. Eventuell noch den Cache im Browser leeren.

Das Sprachpaket kann nur mit dem hier angebotenen SMF2.1-release Archiv verwendet werden!
Gruß Stephan